Supprimer les doublons avec Excel

Publié le par Thierry C.

Le blog est désormais à l'adresse unique :

 

http://www.excel-plus.fr

 

Merci !

Publié dans Techniques avancées

Commenter cet article

Jihan 09/03/2011 16:44



Salut à toi, quand je met ton code "=SI(B2=B1;"DOUBLON";"OK")"


Il me marque #NAME? dans la celule, je n'ai peut etre pas bien compris la méthode mais en gros ce que j'essaye de faire
c'est de trouvé les doublon sur tout une ligne d'un fichier client qui fait plus de 1 000 000 de ligne. j'ai trier sa par ordre alphabetique puis j'ai mis =SI(A1:L1=A2:L2;"DOUBLON";"OK")
 pour qu'il prenne en compte toute la ligne et qu'il la compare a la suivante. il me parque aussi  #name? .



Thierry C. 10/03/2011 23:48



Bonjour,


Cette erreur intervient quand Excel ne trouve pas de référence correcte. Cela veut dire qu'il y a une erreur dans ta saisie. Soit sur les "", soit avec des : ou des
;.


Ce qui est sûr, c'est que ta seconde formule ne peut pas fonctionner comme ça. Juste pour que je sois sûr, tu ne rajoutes pas les " devant le signe = de la formule,
ni après la ) ?


Sinon, il te faut découper ta formule pour voir où il y a erreur. Si tu tapes juste B2=B1, tu devrais obtenir VRAI ou FAUX. Après, tu pourras rajouter la formule
SI.


Dis-moi ce qu'il en est. Si tu as encore des soucis, je peux regarder ton fichier. Envoie-le à contact@excel-plus.fr



Petite-Jeanne 10/01/2009 15:05

Merci beaucoup, super tes explications!.Je ne suis pas sure d'avoir tout compris mais je reviendrais!J'utilise excel pour construire un arbre généalogique, sans aucune aide, ce n'est pas évident. Merci encore.Bonne et heureuse année 2009.

Thierry C. 11/01/2009 18:11


Merci pour tes compliments.
Quoiqu'il en soit, si tu ne comprends pas tous les points, n'hésite pas à revenir vers moi pour que je te donne plus d'explications.
@+